`black` doesn’t actually mix in the user pythonpat...
# development
doesn’t actually mix in the user pythonpath, so it shouldn’t need to use the user’s requirements, should it?
Copy code
ValueError: You are using the lockfile at 3rdparty/python/lockfile.black.txt to install the tool `black`, but it is not compatible with your configuration:

- You have set interpreter constraints (`CPython>=3.6.2`) that are not compatible with those used to generate the lockfile (`CPython<3.10,>=3.7,>=3.8`). You can fix this by not setting `[black].interpreter_constraints`, or by using a new custom lockfile.

To regenerate your lockfile based on your current configuration, run `./pants generate-lockfiles --resolve=black`.
Yeah, a bit of magic
I'm not sure that I understand. It doesn't need the user pythonpath, but does it have different distributions for different python versions?
Oh we check if user code is Py38+ and change the default to match it if so because Black must be run with py38+ to work with 3.8+ code. See rules.py (I'm afk)