# development


11/08/2021, 5:05 PM
seeing a pystache related error in pants CI:
Copy code
Collecting pystache==0.5.4
  Using cached pystache-0.5.4.tar.gz (75 kB)
    ERROR: Command errored out with exit status 1:
     command: /github/home/.cache/pants/pants_dev_deps/Linux.x86_64.x86_64.py39.venv/bin/python3.9 -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-mbzhn3pp/pystache_23cbc1be2d934137805f2203ae353b13/'"'"'; __file__='"'"'/tmp/pip-install-mbzhn3pp/pystache_23cbc1be2d934137805f2203ae353b13/'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code ='"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-pip-egg-info-my0nmexc
         cwd: /tmp/pip-install-mbzhn3pp/pystache_23cbc1be2d934137805f2203ae353b13/
    Complete output (3 lines):
    pystache: using: version '58.1.0' of <module 'setuptools' from '/github/home/.cache/pants/pants_dev_deps/Linux.x86_64.x86_64.py39.venv/lib/python3.9/site-packages/setuptools/'>
    Warning: 'classifiers' should be a list, got type 'tuple'
    error in pystache setup command: use_2to3 is invalid.
WARNING: Discarding <> (from <>). Command errored out with exit status 1: python egg_info Check the logs for full command output.
ERROR: Could not find a version that satisfies the requirement pystache==0.5.4 (from versions: 0.1.0, 0.2.0, 0.3.0, 0.3.1, 0.4.0, 0.4.1, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.5.4)
ERROR: No matching distribution found for pystache==0.5.4
WARNING: You are using pip version 21.2.4; however, version 21.3.1 is available.
You should consider upgrading via the '/github/home/.cache/pants/pants_dev_deps/Linux.x86_64.x86_64.py39.venv/bin/python3.9 -m pip install --upgrade pip' command.

Failed to install requirements from /__w/pants/pants/3rdparty/python/requirements.txt.
Error: Process completed with exit code 1.