https://pantsbuild.org/ logo
#development
Title
# development
h

hundreds-father-404

12/31/2019, 12:44 AM
Any conceptual opposition to renaming
optionable_rule
to
subsystem_rule
? The only time we use it is when registering a Subsystem with the engine — I don’t think we need the flexibility that comes with
Optionable
The first time I read
optionable_rule
, I mistook it for
optional_rule
, which confused me. Likewise,
Subsystem
is a more concrete concept than
Optionable
h

hundreds-breakfast-49010

12/31/2019, 12:45 AM
I've never liked
optionable_rule
as a name. this strikes me as a good change
👍 1
a

aloof-angle-91616

12/31/2019, 1:40 AM
what if we develop a new concept that’s still an Optionable and want to phase out Subsystem? do we want to require people to then change all their own pants plugins? this seems like a matter of lacking documentation for pants’s incredible options system and i’m not sure i fully understand what this buys us.
h

hundreds-breakfast-49010

12/31/2019, 1:41 AM
I think the main problem is that "optionable" is a confusing word. we could change that to something else that is still more general than subsystems
✍️ 2
👖 2
👍 2
a

aloof-angle-91616

12/31/2019, 1:42 AM
in general, i’m a little concerned about changes made in the name of simplifying concepts. making this change seems to add more churn in the v2 engine which unsettled me as we try to make the v2 api more palatable for real use cases.
@hundreds-breakfast-49010 i’m totally ok with that