https://pantsbuild.org/ logo
#development
Title
# development
h

hundreds-father-404

04/29/2020, 6:46 PM
Any opposition to these renames or better alternatives? Asher pointed out last week that they were confusing because he wanted to operate on “file” rather than “directories” * DirectoriesToMerge -> MergeDigestsRequest * DirectoryWithPrefixToStrip -> StripPrefixRequest * DirectoryWithPrefixToAdd -> AddPrefixRequest * DirectoryToMaterialize -> WriteDigest (maybe WriteDigestToBuildRoot?) I wonder if it should be
StripPrefixPrequest
or
StripPrefix
, given that you get back
Digest
, not `StrippedPrefix`:
Copy code
await Get[Digest](StripPrefixRequest(digest))
vs
Copy code
await Get[Digest](StripPrefix(digest))
(I think the latter)