Any opinions on `SnapshotSubset` -> `DigestSubs...
# development
h
Any opinions on
SnapshotSubset
->
DigestSubset
? The name is a misnomer atm because it takes a digest, not a Snapshot.
DigestSubset
would also go nicely with
MergeDigests
a
sure, but the subset is a subset of the snapshot's files, and while that does correspond to lower levels of a merkle tree (and therefore bijective with Digests), the digest itself is somewhat atomic and it's harder for me to understand what a subset of that is
h
I see why Greg used
SnapshotSubset
. It looks like
await Get[Digest](SnapshotSubset)
doesn’t work. While the input is a
Digest
, the output is a
Snapshot
a
we should be able to just add another intrinsic? that should absolutely not be happening, i suspect the ffi types might not be hooked up right