i'm getting this error when attempting to `./pants...
# development
i'm getting this error when attempting to
./pants list
with literally any target spec on pants 2.0.0dev0, and it's only reproing on linux, not osx (i tried two separate linux environments). are both of these failures likely to be from running out of memory (possibly running out of shared memory in LMDB)? this occurs without pantsd as well.
there is a file named
in the curent directory
i can reproduce the first error ("no such file or directory") using docker on my local machine
i think it might be interacting with symlinked workdir
yep!!! fixed it
❤️ 1
will figure out the fix for this later, just disabled this twitter internal feature that was causing the issue
💯 1
doesn't actually seem that easy, working on it
still figuring this out. i was definitely able to reproduce the "no such file or directory" issue at first, but it just seems to pass locally now and fail in our internal CI. i'm going to let it run through all the way locally, since it still takes a long time to run this command
will let you know if i need any more pointers