https://pantsbuild.org/ logo
#development
Title
# development
h

hundreds-breakfast-49010

07/29/2020, 8:22 AM
this is a general and low-priority (for the 2.0 launch) observation, but it seems to me like it would be nice if we could consolidate the various
lift_
methods defined rather haphazardly in
<http://nodes.rs|nodes.rs>
maybe these should be
&self
methods on
Value
and defined in
<http://core.rs|core.rs>
w

witty-crayon-22786

07/29/2020, 4:13 PM
another alternative would be to define them as classes on the Rust side. would make API docs a bit more challenging, but maybe not too much.