https://pantsbuild.org/ logo
#development
Title
# development
h

hundreds-father-404

02/10/2021, 6:24 PM
Looks like we have both the types
WorkunitState
and
WorkUnitState
. Former refers to an individual workunit, if it started and if it finished. The latter refers to
The per-thread/task state that tracks the current workunit store, and workunit parent id.
I think the latter should be renamed. Ideas on a better name?
WorkunitStoreThreadState
?
w

witty-crayon-22786

02/10/2021, 6:41 PM
โ€œstateโ€ applies best to the first usecase
๐Ÿ‘ 1
WorkunitStoreHandle
, maybe
๐Ÿ’ฏ 1
h

hundreds-father-404

02/10/2021, 6:41 PM
@hundreds-breakfast-49010 any thoughts? You added the first type, it looks like, which I agree is a good name
h

hundreds-breakfast-49010

02/10/2021, 6:56 PM
WorkunitState
is about the running/completed state of an individual workunit
so I think that name makes sense
I like stu's suggestion for renaming the 2nd one
๐Ÿ‘ 1