https://pantsbuild.org/ logo
#development
Title
# development
j

jolly-midnight-72759

04/20/2021, 1:30 AM
While trying to run
./pants test src/python/pants/backend/project_info/depende*_test.py
I get the following error for both tests found:
Copy code
============================= test session starts ==============================
collected 0 items / 1 error

==================================== ERRORS ====================================
_ ERROR collecting src/python/pants/backend/project_info/list_targets_test.py __
ImportError while importing test module '/private/var/folders/_0/dml1k4014y3825k3mwt4t81c0000gn/T/process-executionEBPtbP/src/python/pants/backend/project_info/list_targets_test.py'.
Hint: make sure your test modules/packages have valid Python names.
Traceback:
/Library/Developer/CommandLineTools/Library/Frameworks/Python3.framework/Versions/3.8/lib/python3.8/importlib/__init__.py:127: in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
src/python/pants/backend/project_info/list_targets_test.py:7: in <module>
    from pants.backend.project_info.list_targets import ListSubsystem, list_targets
src/python/pants/backend/project_info/list_targets.py:7: in <module>
    from pants.engine.console import Console
src/python/pants/engine/console.py:10: in <module>
    from pants.engine.internals.scheduler import SchedulerSession
src/python/pants/engine/internals/scheduler.py:52: in <module>
    from pants.engine.process import (
src/python/pants/engine/process.py:14: in <module>
    from pants.base.exception_sink import ExceptionSink
src/python/pants/base/exception_sink.py:16: in <module>
    import setproctitle
E   ImportError: dlopen(/Users/raul/.cache/pants/named_caches/pex_root/venvs/16c951b58965c58687475c974b08c8b457cac3e0/3e6f6c8ded13a8d6ae70f8fb5db8ff95d2aebcc0/lib/python3.8/site-packages/setproctitle.cpython-38-darwin.so, 2): Symbol not found: _Py_GetArgcArgv
E     Referenced from: /Users/raul/.cache/pants/named_caches/pex_root/venvs/16c951b58965c58687475c974b08c8b457cac3e0/3e6f6c8ded13a8d6ae70f8fb5db8ff95d2aebcc0/lib/python3.8/site-packages/setproctitle.cpython-38-darwin.so
E     Expected in: flat namespace
E    in /Users/raul/.cache/pants/named_caches/pex_root/venvs/16c951b58965c58687475c974b08c8b457cac3e0/3e6f6c8ded13a8d6ae70f8fb5db8ff95d2aebcc0/lib/python3.8/site-packages/setproctitle.cpython-38-darwin.so
=========================== short test summary info ============================
ERROR src/python/pants/backend/project_info/list_targets_test.py
!!!!!!!!!!!!!!!!!!!! Interrupted: 1 error during collection !!!!!!!!!!!!!!!!!!!!
=============================== 1 error in 0.62s ===============================
I assume I skimmed over an import step in setting up my environment. Please point me in the right direction.
I'm running this on HEAD, version 2.5.0.dev2, and on OS X 10.15.7.
Doing a fresh build, it looks like there is a failure compiling dependencies.
h

hundreds-father-404

04/20/2021, 1:34 AM
Hm, I think you might have a corrupted wheel being used in
/Users/raul/.cache/pants/named_caches/pex_root/venvs/16c951b58965c58687475c974b08c8b457cac3e0/3e6f6c8ded13a8d6ae70f8fb5db8ff95d2aebcc0/lib/python3.8/site-packages/setproctitle.cpython-38-darwin.so
Idk how much storage space you have on your machine - if ample, it would be helpful to rename
.cache/pants
to
.cache/pants_old
so that we can keep anything we need to look into, this might be a bug Otherwise,
rm -rf .cache/pants
j

jolly-midnight-72759

04/20/2021, 1:34 AM
Copy code
In file included from src/setproctitle.c:14:
  In file included from src/spt.h:15:
  In file included from src/spt_python.h:16:
  In file included from /Library/Developer/CommandLineTools/Library/Frameworks/Python3.framework/Versions/3.8/include/python3.8/Python.h:25:
  In file included from /Library/Developer/CommandLineTools/SDKs/MacOSX10.15.sdk/usr/include/stdio.h:64:
  In file included from /Library/Developer/CommandLineTools/SDKs/MacOSX10.15.sdk/usr/include/_stdio.h:75:
  In file included from /Library/Developer/CommandLineTools/SDKs/MacOSX10.15.sdk/usr/include/sys/_types/_va_list.h:31:
  /Library/Developer/CommandLineTools/SDKs/MacOSX10.15.sdk/usr/include/machine/types.h:37:2: error: architecture not supported
  #error architecture not supported
   ^
  fatal error: too many errors emitted, stopping now [-ferror-limit=]
  20 errors generated.
  error: command 'clang' failed with exit status 1
  Building wheel for setproctitle (PEP 517): finished with status 'error'
  ERROR: Failed building wheel for setproctitle
Failed to build setproctitle
ERROR: Failed to build one or more wheels
h

hundreds-father-404

04/20/2021, 1:35 AM
Do you have an M1 mac?
j

jolly-midnight-72759

04/20/2021, 1:36 AM
I've got storage for miles.
No. It is 2017 MacBook Pro.
I did the mv and got the same error.
I mv
~/.cache/pants
just to be sure we are talking about the same dir.
It didn't rebuild everything though.
Do I need to kill
pantsd
?
Now it is rebuilding things.
same error, but my terminal did not capture the full output. Running again but hopefully I can capture more of the run and attach it as a file.
This appears to be the place where it fails.
hmm.. It is a 25mb text file. Maybe I won't upload it. LOL
pip install setproctitle
works
I don't have Xcode installed.
h

happy-kitchen-89482

04/20/2021, 3:32 AM
Hmm this seems familiar
Which python are you using?
MacOS system interpereter?
Those are known to have issues like this
Maybe try a brew- or pyenv-managed interpreter
j

jolly-midnight-72759

04/20/2021, 4:56 PM
I am using pyenv 3.8
I added a tmp
.python-version
version file to force pyenv 3.8.0 being used. I get these errors with this file in place.