fast-nail-5540007/16/2021, 9:19 PM
from https://github.com/pantsbuild/pants/runs/3089689188?check_suite_focus=true. I had added a PyPi package to the lockfile in that PR. Does the lockfile have to be generated with Python 3.7? (I had run it with Python 3.8.)
stderr: Failed to resolve requirements from PEX environment @ /tmp/process-executionRnfOYF/lockfile.pex. Needed manylinux_2_31_x86_64-cp-37-cp37m compatible dependencies for: 1: importlib-metadata>=0.12; python_version < "3.8" Required by: pluggy 0.13.1 pytest 6.2.4 But this pex had no 'importlib-metadata' distributions.
hundreds-father-40407/16/2021, 9:20 PM
fast-nail-5540007/16/2021, 9:29 PM
PY=python3.7 ./pants --tag=-lockfile_ignore lock ::
hundreds-father-40407/16/2021, 9:48 PM
so we should document that requirementPerhaps, but this should be fixed in less than a week. This is the main thing CHris and I are working on