https://pantsbuild.org/ logo
#development
Title
# development
f

fast-nail-55400

07/16/2021, 9:19 PM
Copy code
stderr:
Failed to resolve requirements from PEX environment @ /tmp/process-executionRnfOYF/lockfile.pex.
Needed manylinux_2_31_x86_64-cp-37-cp37m compatible dependencies for:
 1: importlib-metadata>=0.12; python_version < "3.8"
    Required by:
      pluggy 0.13.1
      pytest 6.2.4
    But this pex had no 'importlib-metadata' distributions.
from https://github.com/pantsbuild/pants/runs/3089689188?check_suite_focus=true. I had added a PyPi package to the lockfile in that PR. Does the lockfile have to be generated with Python 3.7? (I had run it with Python 3.8.)
cc @hundreds-father-404
h

hundreds-father-404

07/16/2021, 9:20 PM
Yes, it does have to be w/ 3.7 This is an area of very very active development. Pants will soon try generating with all interpreters and warn/error if some aren't available
f

fast-nail-55400

07/16/2021, 9:29 PM
so we should document that requirement
I am going to run
PY=python3.7 ./pants --tag=-lockfile_ignore lock ::
h

hundreds-father-404

07/16/2021, 9:48 PM
so we should document that requirement
Perhaps, but this should be fixed in less than a week. This is the main thing CHris and I are working on
*`./pants --python-setup-interpreter-constraints='["==3.7.*"]' --tag=-lockfile_ignore lock ::`