Hi! I'm tweaking <https://github.com/pantsbuild/pa...
# development
Hi! I'm tweaking https://github.com/pantsbuild/pants/pull/16488 based on review feedback (thanks), and thus taking the chance to get my dev environment set up properly. I'm on an arm64 mac, so things generally only work with Python >= 3.9. I'm trying to run tests (e.g.
./pants test src/python/pants/core/goals/check_test.py
) and hitting:
Copy code
pex.environment.ResolveError: A distribution for pyyaml could not be resolved for /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/bin/python3.8.
Found 1 distribution for pyyaml that do not apply:
1.) The wheel tags for PyYAML 6.0 are cp38-cp38-macosx_10_14_arm64 which do not match the supported tags of /Applications/Xcode.app/Contents/Developer/Library/Frameworks/Python3.framework/Versions/3.8/bin/python3.8:
I've worked around this locally by increasing the interpreter constraints lower bound
[python].interpreter_constraints = [">=3.9,<3.10"]
, which at least unblocks me running tests. Is there a better way to be forcing a particular Python interpreter/version for a particular machine? (otherwise I'm sure I'll accidentally commit that change at some point)