https://pantsbuild.org/ logo
#development
Title
# development
f

fast-nail-55400

11/15/2022, 4:08 PM
I'm getting a consistent failure to resolve the toolchain.pants.plugin in my pants repo:
Copy code
ERROR: Could not find a version that satisfies the requirement toolchain.pants.plugin==0.25.0
ERROR: No matching distribution found for toolchain.pants.plugin==0.25.0
error occurs if I
--keep-sandboxes=on_failure
and manually invoke the
__run.sh
script in the preserved sandbox. I commented out the
toolchain.pants.plugin
requirement and left in the
hdrhistogram
requirement and that plugin resolves just fine.
I was on train wi-fi. but doesn't explain why
hdrhistogram
resolves nor why I can successfully download the wheel directly from https://files.pythonhosted.org/packages/d4/a4/bf77bf161916edaae7e070936fa8570db8f0b72224[…]cb55d24c38/toolchain.pants.plugin-0.25.0-py3-none-any.whl
e

enough-analyst-54434

11/15/2022, 5:01 PM
I can't recall for sure, but sometimes the purported error is 1 degree separated. If
toolchain.pants.plugin
depends on
pantsbuild.pants
it may be it's that dependency of the
toolchain.pants.plugin
that actually can't be resolved. That then could be explained by things like on an M1 and Python 3.8 got picked (we don't publish a 3.8 M1 wheel for
pantsbuild.pants
).
f

fast-nail-55400

11/15/2022, 5:04 PM
What’s the way to increase pex verbosity with that script? I tried setting
PEX_VERBOSITY=3
when running
__run.sh
to no avail.
p

polite-garden-50641

11/15/2022, 5:05 PM
the plugin actually doesn't announce its dependency on pants...
(in order to allow it to be used w/ multiple pants versions)
f

fast-nail-55400

11/15/2022, 5:06 PM
This is on x86-64 macOS with Python 3.10.7
p

polite-garden-50641

11/15/2022, 5:06 PM
the plugin (and pants AFAIK) doesn't support 3.10 yet.
f

fast-nail-55400

11/15/2022, 5:07 PM
Okay that’s probably it then. This needs a way better error message.
p

polite-garden-50641

11/15/2022, 5:07 PM
agreed.