https://pantsbuild.org/ logo
#development
Title
# development
h

happy-kitchen-89482

01/23/2023, 7:12 PM
Hey folks, there are a few PRs that need cherry-picking into 2.15.x. Please go to https://github.com/pantsbuild/pants/pulls?q=is%3Apr+is%3Aclosed+label%3Aneeds-cherrypick, find your PRs, and cherry-pick them.
Specifically, the relevant authors are @fresh-cat-90827, @bitter-ability-32190, @witty-crayon-22786, @fast-nail-55400, @busy-vase-39202, @late-keyboard-89314
👍 2
To cherry-pick, first ensure you're on latest main, and that your 2.15.x branch is on latest 2.15.x (if you don't have such a branch,
git branch --track 2.15.x origin/2.15.x
will create one). Then on main run
build-support/bin/cherry-pick.sh <pr_number>
When it asks where you want to create the branch, create it on your fork, not on pantsbuild/pants...
I can cherry-pick for you, but then you won't appear as the author in the branch
b

bitter-ability-32190

01/23/2023, 7:18 PM
done
b

busy-vase-39202

01/23/2023, 7:18 PM
I'm fine with you cherry picking mine.
I can't do anything with git today anyway due to a ssh issue that apparently was caused by an OS update last night, sigh.
c

curved-television-6568

01/23/2023, 7:19 PM
tried
xcode-select --install
?
b

busy-vase-39202

01/23/2023, 7:19 PM
Oooh, good idea. Thanks Andreas!
🤞 1
h

happy-kitchen-89482

01/23/2023, 7:32 PM
I'll do yours Carina
b

busy-vase-39202

01/23/2023, 7:33 PM
Thanks!
l

late-keyboard-89314

01/23/2023, 7:33 PM
I can get to mine tomorrow; if it needs to be sooner feel free to do it and steal my authorship 🙂
h

happy-kitchen-89482

01/23/2023, 7:48 PM
Actually @busy-vase-39202 it would be good for you to try and get it working, since your changes tend to be docs changes, and those almost always need to be cherry-picked
if it doesn't work let me know
b

busy-vase-39202

01/23/2023, 7:54 PM
Didn't work. Any other suggestions? I've spent hours today with GH's ssh keys page, and haven't solved this.
<mailto:git@github.com|git@github.com>: Permission denied (publickey).
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.
Fails while in cloned repo that was working fine before.
h

happy-kitchen-89482

01/23/2023, 7:56 PM
Oh boy
b

busy-vase-39202

01/23/2023, 7:57 PM
Yeah. I don't get it.
l

late-keyboard-89314

01/23/2023, 7:57 PM
It’d be weird for an OS update to bork your ssh identities, but have you double checked that
~/.ssh/id_rsa.pub
or whatever key matches what’s in GH account settings still? Worst case I guess you could create a new key
b

busy-vase-39202

01/23/2023, 7:58 PM
I've quadruple checked that. Nuking the key is the only thing left that I haven't tried yet. Changing perms didn't work.
I've had ssh problems for months. The ssh-agent never starts on it own, even though it's been added to keychain a zillion times. So I always end up having to go through the checklist all over again every time I restart. But this is the first time where that's failed to solve the problem.
f

fresh-cat-90827

01/23/2023, 8:08 PM
if there are more PRs that I'd like to get into the release, should I just go the PRs and add the label and the milestone or should this be somehow "approved" first? @happy-kitchen-89482
pardon my confusion - doing this for the first time
h

happy-kitchen-89482

01/23/2023, 8:25 PM
You can just add the label and the milestone, and then run the cherry-pick script, which uses both (and then remove the label, but not the milestone)
f

fresh-cat-90827

01/23/2023, 8:28 PM
Copy code
❯ build-support/bin/cherry_pick.sh 17506
remote: Enumerating objects: 11, done.
remote: Counting objects: 100% (11/11), done.
remote: Compressing objects: 100% (1/1), done.
remote: Total 6 (delta 5), reused 5 (delta 5), pack-reused 0
Unpacking objects: 100% (6/6), 2.29 KiB | 780.00 KiB/s, done.
From <https://github.com/pantsbuild/pants>
 * branch                2.15.x     -> FETCH_HEAD
Switched to a new branch 'cherry-pick-17506-to-2.15.x'
[cherry-pick-17506-to-2.15.x 28ee3d73c] Docs: improve docs on handling option values in cli (#17506)
 Date: Sat Nov 19 23:22:49 2022 +0000
 1 file changed, 2 insertions(+)
? Where should we push the 'cherry-pick-17506-to-2.15.x' branch? AlexTereshenkov/pants

Creating pull request for AlexTereshenkov:cherry-pick-17506-to-2.15.x into 2.15.x in pantsbuild/pants

remote: 
remote: 
To github:AlexTereshenkov/pants.git
 * [new branch]          HEAD -> cherry-pick-17506-to-2.15.x
branch 'cherry-pick-17506-to-2.15.x' set up to track 'origin/cherry-pick-17506-to-2.15.x'.
could not request reviewer: 'app/stuhood' not found
is seeing
could not request reviewer: 'app/stuhood' not found
expected?
You can just add the label and the milestone, and then run the cherry-pick script, which uses both (and then remove the label, but not the milestone)
Many thanks! Should I remove the label "needs-cherrypick" from the original PR (where the actual work is done) as soon as I opened the cherry-picking PR or should I wait for that to be merged first (if it matters at all)?
h

happy-kitchen-89482

01/23/2023, 9:44 PM
Either way. Once the cherrypick PR is out, we don't need the label to remind us
1
b

busy-vase-39202

01/23/2023, 10:41 PM
Turns out the OS install was fubared. After an installation do-over, then generating new keys, ssh and git are back at last. Hurrah!
🤦‍♀️ I spoke too soon. 😭
I have no ideas on what else to try. Suggestions?
l

late-keyboard-89314

01/24/2023, 5:00 PM
My cherry-pick is up: https://github.com/pantsbuild/pants/pull/18077
I have no ideas on what else to try. Suggestions?
If git and SSH aren’t working after a fresh OS install, I’d suggest calling a priest because your machine is clearly haunted.
b

busy-vase-39202

01/24/2023, 5:04 PM
It's only ssh that keeps going fubar. Git is fine afaik. But git remote operations require ssh, so... Anyway, it's working for the moment. Though that doesn't seem to guarantee it will continue to. Augh.
f

fast-nail-55400

01/24/2023, 7:25 PM
But git remote operations require ssh
Not the only way: You can also make a GitHub Personal Access Token and use it with a https:// git repo URL. https://docs.github.com/en/authentication/keeping-your-account-and-data-secure/creating-a-personal-access-token#using-a-token-on-the-command-line
Also if you run
ssh -v <mailto:git@github.com|git@github.com>
, can you share that output?
b

busy-vase-39202

01/24/2023, 8:16 PM
Taking this to DMs.
👍 1
f

fresh-cat-90827

01/27/2023, 9:06 PM
I am done with cherry-picking all my PRs (the docs and tutorials)
h

happy-kitchen-89482

01/27/2023, 10:27 PM
I will publish!
f

fresh-cat-90827

01/27/2023, 10:28 PM
Thanks a lot Benjy, sorry it took some time - i had a lot of PRs