Hey everyone :smile: Hope ya'll are doing okay I'...
# general
Hey everyone 😄 Hope ya'll are doing okay I've hit an issue that is causing pantsbuild to not be able to run the goal [conan-prep]. So after running a pants clean-all and wiping the caches, configparser upgraded it's version to 5.0.0 which is only python 3 compatible; however, we're on pants 1.14.0 and using python 2. Is there a way we can pin the version of configparser 4.0.2 somewhere -- possibly in the pants.ini file? This started failing the day configparser 5.0.0 came out.
Copy code
Package SourcePackage(u'file:///Users/<name>/.cache/pants/python_cache/requirements/CPython-2.7.16/configparser-5.0.0.tar.gz') is not translateable by ChainedTranslator(WheelTranslator, EggTranslator, SourceTranslator)
Any idea for any actions I can do to patch this? Thanks ahead of time for any help!!
Hmm that is quite an old Pants version, I guess we were using the configparser backport back then...
You might be able to override by adding
to the
config file entry in the GLOBAL scope.
Hmmm, when I tried overriding in a plugins block, I was hitting an error to use configparser 3.5.0. Once I did that, I then hit the same 5.0.0 issue. Does this seem right?
Copy code
plugins = ['configparser==3.5.0']
On a side note, I was able to just go to the ~/.cache dir and delete 5.0.0 configparser in there and add 4.0.2. But that workaround is pretty hacky