https://pantsbuild.org/ logo
#general
Title
# general
f

few-alarm-32433

06/04/2020, 7:32 PM
have any of you seen this before?
Copy code
15:27:16 00:49   [pyprep]
15:27:16 00:49     [interpreter]
                   Invalidated 602 targets.
15:27:20 00:53     [build-local-dists]
15:27:20 00:53     [requirements]
                   Invalidated 149 targets.ERROR: Double requirement given: six<2,>=1.9.0 (already in six==1.15.0, name='six')
happening somewhere in `~/.cache/pants/setup/bootstrap-Darwin-x86_64/1.26.0_py37/lib/python3.7/site-packages/pex/resolver.py”, line 521, in resolve_distributions I tried making sure the bootstrap’s pip is upgraded 20.1.1, no luck.
i

important-librarian-62877

06/04/2020, 7:34 PM
I ran into this issue and it was due to having that requirement defined in two BUILD files with different versions. May not be your issue, but worth a double check.
❤️ 1
w

witty-crayon-22786

06/04/2020, 7:41 PM
yea, that’s what it would be here.
would take a look in
./pants dependencies --transitive
for the dupe. or in a grep of
./pants filedeps --transitive
for context:
1.26.x
uses pex 2, which uses pip under the hood as its resolver. a lot changed.
thanks for chiming in Connor!
❤️ 1
👍 1
f

few-alarm-32433

06/04/2020, 8:05 PM
thank you! I hadn’t looked hard enough.
./pants dependencies --transitive
helped
4 Views