https://pantsbuild.org/ logo
#general
Title
# general
m

modern-wolf-36228

10/12/2021, 9:20 AM
Why do I have this:
ERROR: No matching distribution found for pantsbuild.pants==2.8.0.dev4
? I can install
pantsbuild.pants==2.8.0.dev4
via pip, but when I change the version on the
pants.toml
I have the error. ๐Ÿค”
c

curved-television-6568

10/12/2021, 9:39 AM
Do you have a custom
[python-repos].indexes
in your
pants.toml
?
m

modern-wolf-36228

10/12/2021, 9:40 AM
no
c

curved-television-6568

10/12/2021, 9:42 AM
Hmmโ€ฆ strange, just tried it and it works (Iโ€™m using a custom pypi index, though..)
m

modern-wolf-36228

10/12/2021, 9:43 AM
Copy code
[GLOBAL]
pants_version = "2.8.0.dev4"
backend_packages.add = [
    "pants.backend.python",
    "pants.backend.python.lint.black",
    "pants.backend.python.lint.flake8",
    "pants.backend.python.lint.isort",
    "pants.backend.python.typecheck.mypy",
]

[source]
root_patterns = ["src/python/", "/"]

[python-infer]
inits = true

[python-setup]
interpreter_constraints = ["CPython==3.8.*"]
should be simple enough, I guess?
c

curved-television-6568

10/12/2021, 9:43 AM
Do you get a list of versions it does know about? I get this when trying with dev5 for instance:
Copy code
ERROR: Could not find a version that satisfies the requirement pantsbuild.pants==2.8.0.dev5 (from versions: 0.0.17, 0.0.18, 0.0.20, 0.0.21, 0.0.22, 0.0.23, 0.0.24, 0.0.25, 0.0.26, 0.0.27, 0.0.28, 0.0.29, 0.0.30, 0.0.31, 0.0.32, 0.0.33, 0.0.34, 0.0.35, 0.0.36, 0.0.37, 0.0.38, 0.0.39, 0.0.40, 0.0.41, 0.0.42, 0.0.43, 0.0.44, 0.0.45, 0.0.46, 0.0.47, 0.0.48, 0.0.49, 0.0.50, 0.0.51, 0.0.52, 0.0.53, 0.0.54, 0.0.55, 0.0.56, 0.0.57, 0.0.58, 0.0.59, 0.0.60, 0.0.61, 0.0.62, 0.0.63, 0.0.64, 0.0.65, 0.0.66, 0.0.67, 0.0.68, 0.0.69, 0.0.70, 0.0.71, 0.0.72, 0.0.73, 0.0.74, 0.0.75, 0.0.76, 0.0.77, 0.0.79, 0.0.80, 0.0.81, 0.0.82, 1.0.0, 1.0.1, 1.1.0, 1.2.0, 1.2.1, 1.3.0, 1.4.0, 1.5.0, 1.6.0, 1.7.0, 1.15.0, 1.16.0, 1.17.0, 1.18.0, 1.19.0, 1.20.0, 1.21.0, 1.22.0, 1.23.0, 1.24.0, 1.25.0, 1.26.0, 1.27.0, 1.28.0, 2.5.0.dev2, 2.5.0.dev3, 2.5.0rc0, 2.5.0rc1, 2.5.0rc2, 2.5.0rc3, 2.5.0, 2.5.1rc0, 2.5.1rc1, 2.5.1rc2, 2.5.1rc3, 2.5.1rc4, 2.5.1rc5, 2.5.1rc6, 2.5.1, 2.5.2rc0, 2.5.2rc1, 2.5.2rc2, 2.5.2rc3, 2.5.2, 2.6.0.dev0, 2.6.0.dev1, 2.6.0.dev2, 2.6.0rc0, 2.6.0rc1, 2.6.0rc2, 2.6.0rc3, 2.6.0rc4, 2.6.0, 2.6.1rc0, 2.6.1rc1, 2.6.1rc2, 2.6.1rc3, 2.6.1, 2.7.0.dev0, 2.7.0.dev1, 2.7.0.dev2, 2.7.0.dev3, 2.7.0.dev4, 2.7.0rc0, 2.7.0rc1, 2.7.0rc2, 2.7.0rc3, 2.7.0rc4, 2.7.0rc5, 2.7.0, 2.7.1rc0, 2.7.1rc1, 2.8.0.dev0, 2.8.0.dev1, 2.8.0.dev2, 2.8.0.dev3, 2.8.0.dev4)
ERROR: No matching distribution found for pantsbuild.pants==2.8.0.dev5
m

modern-wolf-36228

10/12/2021, 9:43 AM
yes, I do
it says the same thing as you, but without the 2.8.0.dev4 on the list ๐Ÿ˜…
๐Ÿ˜… 1
c

curved-television-6568

10/12/2021, 9:44 AM
So, could it be something on your end that has cached what versions there are, so it doesnโ€™t get a list that is up to date?
m

modern-wolf-36228

10/12/2021, 9:46 AM
hmm, I've tried
python -m pip install
now, and I have the same behavior
not related to pants then
c

curved-television-6568

10/12/2021, 9:47 AM
progress at least ๐Ÿ™‚
m

modern-wolf-36228

10/12/2021, 9:55 AM
ty anyway ๐Ÿ˜—
a

adorable-engine-71736

10/12/2021, 10:02 AM
im seeing the same - or at least i cant install from pypi using
--pre
and
==2.8.0.dev4
- its there on pypi (the website) tho, so i guess there must be something fu with pypi's index
m

modern-wolf-36228

10/12/2021, 10:03 AM
I've clean the cache, now I can't use install in either way ๐ŸงŒ
a

adorable-engine-71736

10/12/2021, 10:07 AM
8/
searching for bugs i can see stuff about fastly caching, but tried to clear cache with
curl -LX
which seems to work, but made no difference to installing
hmm, im wondering if its because its listed as cp37 - i guess this means cpython 3.7 only
(for linux)
m

modern-wolf-36228

10/12/2021, 10:12 AM
yeap, that should be it
missing wheels on 2.8.0.dev4 then ๐Ÿ˜—
a

adorable-engine-71736

10/12/2021, 10:17 AM
@curved-television-6568 should we raise a ticket for this ?
c

curved-television-6568

10/12/2021, 11:31 AM
Might as well. Iโ€™m not sure how to fix that, donโ€™t think I can, even. (permissions). The US based maintainers will pick this up as soon as they wake up, Iโ€™m certain.
๐Ÿ™Œ 1
Thanks for finding this, and sorry for the trouble.
a

adorable-engine-71736

10/12/2021, 11:38 AM
m

modern-wolf-36228

10/12/2021, 11:39 AM
I'm using
PANTS_SHA=45d9754234c688a3c9e163c2f014803993f6b6c9
in the meantime, jfyk ๐Ÿ˜Ž
๐Ÿ‘ 1
h

hundreds-father-404

10/12/2021, 2:01 PM
It's because the release wasn't finishing because we exceeded the size limit of PyPI (20 GB). Stu's two factor got messed up when changing phones and no one was online last night with permissions to delete old dev releases. He plans to finish the release today Sorry for the confusion!
๐Ÿ™Œ 1
๐Ÿ‘ 1
w

witty-crayon-22786

10/12/2021, 3:52 PM
itโ€™s time to improve our release automation. sorry about that!
๐Ÿ‘ 1
โž• 1
p

polite-garden-50641

10/12/2021, 4:10 PM
got it!
w

witty-crayon-22786

10/13/2021, 4:44 AM
this was released officially a few hours ago: thanks for the patience!
๐ŸŽ‰ 1
๐Ÿš€ 1
4 Views