https://pantsbuild.org/ logo
#general
Title
# general
g

gentle-hydrogen-65984

12/04/2021, 7:24 PM
Hi, I'm on pants 1.27.0 building scala with local cache (read/write) + s3 cache (read only from laptop, its written from CI). I notice things get slow with rsc compiler at this callstack.
sbt.internal.inc.Incremental$.prune
seems like its looking in
.pants.d/**
to clear out old things? I switch branches a lot so its quite big (
incremental_caching=False
also, I think we had problems):
Copy code
$> du -sh .pants.d/compile
5.3G	.pants.d/compile
$> du -sh .pants.d/local_artifact_cache
2.7G	.pants.d/local_artifact_cache
Is there anyway to disable that pruning? I already set
max_entries_per_target
to a big number (well actually, I modified the code so it doesnt even do the pruning, then I clean it in a cron daily), but this seems like a different prune controlled by zinc? Any ideas how I can skip this one too?
h

happy-kitchen-89482

12/04/2021, 10:46 PM
Hmm yes this looks like it's in Zinc, and I don't see a way to turn it off (although maybe there is one buried deep in the Zinc code).
We'll have Scala support in Pants 2 soon, and that won't use Zinc, FWIW