https://pantsbuild.org/ logo
#general
Title
# general
p

proud-dentist-22844

06/13/2022, 10:50 PM
I just tried to run
./pants export ::
(pants 2.11.0) and ran into a pex error
Copy code
pex.environment.ResolveError: A distribution for pyyaml could not be resolved in this environment.Found 1 distribution for pyyaml that do not apply:
1.) The wheel tags for PyYAML 6.0 are cp36-cp36m-manylinux2010_x86_64, cp36-cp36m-manylinux1_x86_64, cp36-cp36m-manylinux_2_5_x86_64, cp36-cp36m-manylinux_2_12_x86_64 which do not match the supported tags of /usr/bin/python3.10:
...
17:41:34.48 [ERROR] 1 Exception encountered:

  ExportError: Failed to write virtualenv for the resolve 'python-default' (using CPython==3.6.*) to dist/export/python/virtualenvs/python-default
Any hints on how to figure out what this is complaining about?
1
Export_PEX_Full_traceback
Hmm. I narrowed it down.
./pants export pants-plugins/::
This directory uses only one resolve
pants-plugins
, and that resolve is set to use
CPython==3.9.*
. The pants-plugins resolve only has one requirement
pantsbuild.pants<2.12,>=2.11.0rc0
, created with:
Copy code
pants_requirements(
    name="pants",
    resolve="pants-plugins",
    testutil=False,
)
And yet I still get an error message that looks like PEX is trying to use
/usr/bin/python3.10
even though it should be using python3.9 (which pants itself is already happily using). So, at least with export, pex seems to be getting the wrong interpreter.
Ah. It must have been fixed already. Updating from pants 2.11.0 to either 2.11.1rc2 or 2.12.0rc2 fixes it.
👍 1
h

hundreds-father-404

06/14/2022, 3:41 PM
Okay glad it's fixed
4 Views