https://pantsbuild.org/ logo
#general
Title
# general
b

brainy-solstice-27042

10/12/2022, 4:28 PM
Is there any way to get pants 1.30 to give us any more information about this message? I've tried the
--print-exception-stacktrace
and
-ldebug
but that doesn't have any specific information about what file it was missing. I've cleared the cache for pants but still no luck
Copy code
Exception: Error { kind: Io(Os { code: 2, kind: NotFound, message: "No such file or directory" }), paths: [] }
w

witty-crayon-22786

10/12/2022, 4:31 PM
blargh… sorry for the trouble. rust’s default error messages are the operating system’s messages, verbatim.
if you’re able to use strace on this machine, you can see what syscall failed that way?
if not, you might try running pants from source on the 1.30.x branch, and adding debug output
b

brainy-solstice-27042

10/12/2022, 4:32 PM
This is run in a docker container, so maybe there's access to the syscall, I'll try that approach
w

witty-crayon-22786

10/12/2022, 4:32 PM
(the best i can say is that things have improved a ton in 2.x)
you’ll need to add some extra privileges to the container in order to strace, but yea.
b

brainy-solstice-27042

10/12/2022, 4:32 PM
Yeah, we have that on the our list to do, just a bit of a change for the rest of our setup at this time
I found the directory that was raising that error, is there any way I can tell pants to ignore that directory entirely? There's never a need to have a BUILD file in that location of our repo, so I'd like to tell pants to ignore it. I am playing with the pants_ignore.add however pants is still throwing an error when I run
./pants test ::
because it sees the directory I don't want it to see
Nevermind, I just had the wrong pattern in the ignore. Got things working
5 Views