I'm evaluating Pants for a repository and I'm having trouble understanding build and test works for other versions of python.
Currently my CI uses python 3.8 but I packages builded with python 3.9.
Everytime I try to export the venv I get that error message:
If I create a venv with 3.8 it works, but directly from 3.10 do not work.
01/31/2023, 2:31 PM
Well, it looks like you have interpreter constraints that say you need CPython 3.8 (
) but CI has no CPython 3.8 interpreter installed. If your project can actually work with CPython 3.9 or 3.10 in addition to 3.8, you need to change your interpreter constraints. If not, you need to install a CPython 3.8 interpreter in CI.
01/31/2023, 2:32 PM
I understand now. I was think pants was capable of creating a environment with requested version for me.