https://pantsbuild.org/ logo
#general
Title
# general
h

high-energy-73119

01/31/2023, 12:59 PM
I'm evaluating Pants for a repository and I'm having trouble understanding build and test works for other versions of python. Currently my CI uses python 3.8 but I packages builded with python 3.9. Everytime I try to export the venv I get that error message:
e

enough-analyst-54434

01/31/2023, 2:00 PM
You have a partial Python 3.9 interpreter install: https://github.com/pantsbuild/pex/issues/1027#issuecomment-684166485 You'll need to install a missing package to complete your Python 3.9.
h

high-energy-73119

01/31/2023, 2:08 PM
Now my error is like this.
If I create a venv with 3.8 it works, but directly from 3.10 do not work.
e

enough-analyst-54434

01/31/2023, 2:31 PM
Well, it looks like you have interpreter constraints that say you need CPython 3.8 (
CPython==3.8.*
) but CI has no CPython 3.8 interpreter installed. If your project can actually work with CPython 3.9 or 3.10 in addition to 3.8, you need to change your interpreter constraints. If not, you need to install a CPython 3.8 interpreter in CI.
h

high-energy-73119

01/31/2023, 2:32 PM
I understand now. I was think pants was capable of creating a environment with requested version for me.
e

enough-analyst-54434

01/31/2023, 2:33 PM
Aha. Definitely not.
4 Views