powerful-eye-5840704/21/2023, 12:02 PM
If you modify the third-party requirements of a resolve then you must regenerate its lockfile by running theHow do I see/trigger this warning? I have pandas==1.4.3 in the requirements, and generated lockfile that includes this version:goal. Pants will display an error if a lockfile is no longer compatible with its updated requirements.
Now, if I modify requirements.txt to bump pandas version pandas==1.5.3, and run
"project_name": "pandas", "version": "1.4.3"
there's no warning that requirements do not match the resolve - is there a way to check this that's builtin in pants? I want - maybe in the CI check - to make sure that when requirements.txt get upgraded, developers generate lockfiles and commit them to the repository as well. Thanks!
pants test ::
enough-analyst-5443404/21/2023, 12:34 PM
powerful-eye-5840704/21/2023, 1:31 PM
Does any test or code under test actually use pandas?yes
Also, I assume you have lock files turned
[python] interpreter_constraints = ["==3.8.*"] enable_resolves = true [python.resolves] python-default = "lockfiles/default.lock"
Dependency on pandas not satisfied, 1 incompatible candidate found: 1.) pandas 1.4.3 does not satisfy the following requirements: ==1.5.3 (via: pandas==1.5.3)