I'm trying to run `./pants run --debug-adapter foo...
# general
I'm trying to run
./pants run --debug-adapter foo/cli.py
. In my
I have
interpreter_constraints = ["CPython==3.10.*"]
yet I see
Copy code
pex.environment.ResolveError: A distribution for sqlalchemy could not be resolved for /usr/bin/python3.7.
Found 1 distribution for sqlalchemy that do not apply:
1.) The wheel tags for SQLAlchemy 1.4.27 are cp310-cp310-manylinux_2_17_x86_64, cp310-cp310-manylinux_2_5_x86_64, cp310-cp310-manylinux1_x86_64, cp310-cp310-manylinux2014_x86_64 which do not match the supported tags of /usr/bin/python3.7:
... 484 more ...
Pants wanting to use python3.7 for tools has been very thorny
For get test coverage to work I had to add the following to my
Copy code
report = ["xml"]
global_report = true
interpreter_constraints = ["CPython==3.10.*"]
because it wasn't able to understand newer python syntax
That trick doesn't work for
Upgrading my version of pants to
pants_version = "2.15.0"
appears to have resolved the issue