https://pantsbuild.org/ logo
#general
Title
# general
c

calm-ambulance-65371

04/26/2022, 8:26 PM
Well this is confusing:
Copy code
⟩ ./pants generate-lockfiles --resolve=all
15:24:21.34 [INFO] Completed: Generate lockfile for all
15:24:21.34 [ERROR] 1 Exception encountered:

  ProcessExecutionFailure: Process 'Generate lockfile for all' failed with exit code 1.
stdout:

stderr:
ERROR: Cannot install pantsbuild-pants==2.11.0rc0, pantsbuild-pants==2.11.0rc1, pantsbuild-pants==2.11.0rc2, pantsbuild-pants== 
The conflict is caused by:
     pantsbuild-pants 2.11.0rc4 depends on pex==2.1.80
     pantsbuild-pants 2.11.0rc3 depends on pex==2.1.79
     pantsbuild-pants 2.11.0rc2 depends on pex==2.1.78
     pantsbuild-pants 2.11.0rc1 depends on pex==2.1.75
     pantsbuild-pants 2.11.0rc0 depends on pex==2.1.72