https://pantsbuild.org/ logo
#general
Title
# general
e

echoing-farmer-15630

03/30/2022, 8:41 PM
Sigh... yeah, I don't get this at all.
interpreter_constraints
is
["CPython==3.9.*"]
,
resolves_to_interpreter_constraints="{'python-default': ['==3.9.*']}"
, and yet trying
Copy code
./pants --no-process-cleanup generate-lockfiles --generate-lockfiles-resolve="['python-default']"
...gets me that
ERROR: Package 'aiofiles' requires a different Python: 3.10.2 not in '<4.0,>=3.6'
error. The resulting execution still referenced something in my ~/.cache/pants directory so I nuked that,
./.pants.d
and
.pids
and started from scratch.... same thing. Weird. I'll try it with rc1 tomorrow (late over here). Very strange.
1