03/30/2022, 6:10 PM
Assume that I am using conda to manage my dependencies in the past where I specify the following, and my code uses Python 3.9 features
Copy code
  - python=3.9.5
My question is, to use pants, do I have to put interpreter_constraints = [“==3.9.*“]. Or I can put interpreter_constraints = [“>=3.6.*“] (for example). I guess, my question becomes, when pants run my codes, will it get (somehow : ) ) python39 instead of python36? If yes, how to make it do it? or it wont, it will just use the interpreter it found.