https://pantsbuild.org/ logo
#general
Title
# general
j

jolly-midnight-72759

11/10/2020, 3:31 PM
This might be related or a new problem, but it is having trouble finding the correct interpreters:
Copy code
Exception message: 1 Exception encountered:

  ProcessExecutionFailure: Process 'Find interpreter for constraints: CPython>=3.6' failed with exit code 102.
stdout:

stderr:
Could not find a compatible interpreter.

Examined the following interpreters:
1.) /usr/bin/python2.7 CPython==2.7.17

No interpreter compatible with the requested constraints was found:
  Version matches CPython>=3.6



(Use --print-stacktrace to see more error details.)
buildkite-agent@raulcicd:~/builds/raulcicd-chartbeat-net-1/chartbeat/lint-check$ python3.6
Python 3.6.9 (default, Oct  8 2020, 12:12:24)
[GCC 8.4.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>>