https://pantsbuild.org/ logo
#general
Title
# general
e

enough-analyst-54434

05/28/2020, 10:05 PM
Aha - ok. So on that version of pants I think we have 2 issues to fix: 1. pin setuptools low without hacking BUILDs. 2. upgrade pex from 1.6.7 to 1.6.12 For 1, we support constraints.txt in newer Pants but you don't have that so I think we can use the
[pytest] requirements
option instead. If you don't have that in your pants.ini, please add:
Copy code
[pytest]
requirements: ["pytest>=3.0.7,<3.7", "setuptools<45"]
The remove your BUILD addition of a setuptools<45 dependency and re-run the tests. Before the re-run you'll need to clean-all unfortantely. It looks like that option is not marked to invalidate things in Pants 1.16.
👍 1