https://pantsbuild.org/ logo
#general
Title
# general
a

ancient-stone-50795

11/07/2016, 10:56 PM
@brash-oxygen-26029 is getting an error trying to work in pants master:
Copy code
~/Development/pants master ./pants help-all --verbose
    Updating registry `<https://github.com/rust-lang/crates.io-index>`
error: An unknown error occurred
and I think I just ran into something similar:
Copy code
./pants --help-all
A rust installation could not be found, installing via the instructions at <https://www.rustup.rs> ...
info: downloading installer
info: syncing channel updates for 'stable-x86_64-apple-darwin'
info: downloading component 'rustc'
 41.2 MiB /  41.2 MiB (100 %)   3.4 MiB/s ETA:   0 s                
info: downloading component 'rust-std'
 54.1 MiB /  54.1 MiB (100 %)   3.4 MiB/s ETA:   0 s                
info: downloading component 'rust-docs'
  6.7 MiB /   6.7 MiB (100 %)   3.4 MiB/s ETA:   0 s                
info: downloading component 'cargo'
info: installing component 'rustc'
info: installing component 'rust-std'
info: installing component 'rust-docs'
info: installing component 'cargo'
info: default toolchain set to 'stable'

  stable installed - rustc 1.12.1 (d4f39402a 2016-10-19)

info: using existing install for 'stable-x86_64-apple-darwin'
info: override toolchain for '/Users/zundel/Src/pants-release' set to 'stable-x86_64-apple-darwin'

  stable-x86_64-apple-darwin unchanged - rustc 1.12.1 (d4f39402a 2016-10-19)

    Updating registry `<https://github.com/rust-lang/crates.io-index>`
 Downloading fnv v1.0.3
error: unable to get packages from source

To learn more, run the command again with --verbose.
~/src/pants-release master