https://pantsbuild.org/ logo
#general
Title
# general
d

damp-mouse-24788

08/08/2018, 5:57 AM
hi.. I added python 3 compatible module and the linting is failing with this error now:
Copy code
use_manylinux=python_setup.use_manylinux)
  File "/Users/jagas005/.cache/pants/setup/bootstrap-Darwin-x86_64/1.9.0rc1/lib/python2.7/site-packages/pex/resolver.py", line 453, in resolve
    return resolver.resolve(resolvables_from_iterable(requirements, builder))
  File "/Users/jagas005/.cache/pants/setup/bootstrap-Darwin-x86_64/1.9.0rc1/lib/python2.7/site-packages/pex/resolver.py", line 248, in resolve
    dist = self.build(package, resolvable.options)
  File "/Users/jagas005/.cache/pants/setup/bootstrap-Darwin-x86_64/1.9.0rc1/lib/python2.7/site-packages/pex/resolver.py", line 323, in build
    dist = super(CachingResolver, self).build(package, options)
  File "/Users/jagas005/.cache/pants/setup/bootstrap-Darwin-x86_64/1.9.0rc1/lib/python2.7/site-packages/pex/resolver.py", line 206, in build
    raise Untranslateable('Package %s is not translateable by %s' % (package, translator))

Exception message: Package SourcePackage(u'file:///Users/jagas005/Documents/project/data-services/.pants.d/python-setup/resolved_requirements/CPython-3.6.4/html-1.16.tar.gz') is not translateable by ChainedTranslator(WheelTranslator, EggTranslator, SourceTranslator)
5 Views