Hi pants people! I’m getting some behavior that se...
# general
Hi pants people! I’m getting some behavior that seems counterintuitive to me. I’m hoping that someone can help shed some light. Note that I’m fairly new to pants. Until recently, we’ve been running a single CI command to build and publish everything. We used a superset of
pants setup-py --changed-parent=HEAD~1
on CI, and it was the first time we introduced the
flag. However, the next time I ran this it failed with this error:
FAILURE: setup-py target(s) must provide an artifact.
This is happening here on 1.8.0: https://github.com/pantsbuild/pants/blob/release_1.8.0/src/python/pants/backend/python/tasks/setup_py.py#L621 The setup-py plugin will raise an error when it’s listed as a goal and no targets are defined. It worked when I first added it, but the very next build failed because nothing changed. Is there something I’m missing here? It seems like the setup-py plugin should silently return, and I assume that setup-py is regularly used.