https://pantsbuild.org/ logo
#general
Title
# general
b

brief-engineer-67497

11/14/2018, 2:28 PM
-ldebug
does not provide any more informations … any ideas ?
e

enough-analyst-54434

11/14/2018, 3:52 PM
No ideas beyond a brute foce
./pants clean-all
. When building one jar from more than one input jar the jar tool we use attempts to read the jar entries directly from the input jars without unpacking them. It sounds like the error is occuring in this bit of trickery (it's a speed hack).
b

brief-engineer-67497

11/14/2018, 3:52 PM
I already tried the
./pants clean-all
and even to clean the coursier cache :s
a

aloof-angle-91616

11/14/2018, 6:17 PM
i would expect you would have to
rm /home/lorilan/dev/platform/dist/foo.jar
, or
rm -r dist/
.
./pants clean-all
deletes the local cache and some other stuff but not
dist/
i actually had this exact same error message like down to the expected bytes but it was on a command line which produced a
.tar.gz
and it would fail i think because i had interrupted the
tar
command and the file was invalid -- removing the file resolved this
b

brief-engineer-67497

11/15/2018, 3:25 PM
thanks for the reply. Actually a change in the build I was not aware of caused this crash. Not sure exactly what caused it. I cleaned the changes and now it works !