https://pantsbuild.org/ logo
#general
Title
# general
b

brief-engineer-67497

12/05/2018, 5:08 PM
if I do
./pants test my_target
it works but it appears when I do
./pants test ./::
e

enough-analyst-54434

12/05/2018, 5:50 PM
Well, it's due to an underlying jvm `LinkageError`: https://github.com/pantsbuild/pants/blob/12711f2dc295fdda526cf9fab17146b87154ed08/src/java/org/pantsbuild/tools/junit/impl/SpecParser.java#L91-L95 That implies, in the :: case - where you attempt to combine all repo classpaths - some element of the classpath needed by
com.mediarithmics.api.common.play.ControllerUtilsTest
has an unexpected api - ie, it's the wrong version, ie an incompatible version forced by some other part of your codebase directly or indirectly.
b

brief-engineer-67497

12/05/2018, 5:57 PM
Thank you for the pointer !
I solved it by using
--no-test-junit-fast
which made me understand how it worked
I tried this option thinking it would spawn a process per testsuite which it did not
e

enough-analyst-54434

12/05/2018, 5:59 PM
Great - thanks for digging. It's hard to maintain an unconflicted global classpath, and this works around your conflict. You still have the conflict though and, if possible ~easily, its good to solve those. It's very likely not possible or practical though.
b

brief-engineer-67497

12/05/2018, 6:02 PM
well I'm not sure we need it, the linking errors happens only in test sources … and anyway I have to go forward with the next issue XD
2 Views