<@U04S45AHA> I don’t appear to be able to run pant...
# general
@enough-analyst-54434 I don’t appear to be able to run pants from source outside of the pants repo any more, and I used to be able to… If I run with
I get told
Could not satisfy all requirements for pantsbuild.pants.contrib.python.checks.checker==1.14.0.dev1:
and if I don’t, I get told “Path “contrib/python/src/python/pants/contrib/python/checks/checker” does not contain any BUILD files.” - any idea what I need to do about this?
As a bandaid - subtract that plugin.
So, in the suggested:
Copy code
  PANTS_PYTHONPATH="+['/path/to/pants/repo/contrib/python/src/python']" \
  PANTS_BACKEND_PACKAGES="+['pants.contrib.python.checks']" \
  PANTS_VERSION=1.2.0-dev0 \
  /path/to/pants/repo/pants compile ::
Kill the PANTS_BACKEND_PACKAGES]"+..." bit.
Maybe s/plugin/backend/ - but you get the idea. I'll try to page in the deeper fix here in a little bit.
ok, thanks 🙂
If I run with PANTS_DEV=0 - no issues, I can lint python files (including checkstyle) from another repo. I suspect your failure to do so is related to Stu's bug https://github.com/pantsbuild/pants/issues/7158 and I now suspect Twitter doesn't include the checker wheel in it's cheeseshop. These guys: https://pypi.org/project/pantsbuild.pants.contrib.python.checks.checker/1.14.0.dev2/#files