I’m running into an issue when bundling my Javascr...
# general
I’m running into an issue when bundling my Javascript webapp. It is not picking up changes I made to any JS files and seems to be using the old version of the artifact. Is there anyway I can validate that changes I make to a Javascript file will be picked up when running node bundle and overwrite the affected cached artifact? The binary is structured in that it builds a JAR for our Play API application and includes the JS bundle with it. I tested this by making a change to one of the JS file and when rebuilding the JAR, it says 1 invalidated target which is what I want. However, when I “unzip” the JAR it does not show the changes I made to that JS file. In addition, when I run the JAR and load the web application, it does not reflect the code logic change I made. For all node build tasks, it is configured to use the Pants contribution package (pants.contrib.node.tasks.node_build...) and I am on
Pants 1.16.0
. What has worked was bumping the
which will rebuild the entire JAR with new artifacts; however, the expected behavior is that I can reuse the cached artifact and any changes should only override the affected artifacts.