<@U051221NF> thanks for that, I think the details ...
# general
@happy-kitchen-89482 thanks for that, I think the details were a bit sparse. We've done a bit more digging and have a specific ask. Is it possible to upgrade the version of setuptools that pants uses. Context:
pants_version: 1.24.0rc1
we're trying to run
./pants test
with a target that uses the google-auth library. There is a specific issue with the library which breaks on older versions of
. Running a pytest after upgrading our setuptools version to
passes fine. When running it through pants, pants enforces
setuptools 40.6.3
. We tried to get around this by adding in
plugins: ["setuptools_scm", "setuptools==45.1.0"]
to our pants.ini, but then we get this error.
Exception caught: (pkg_resources.VersionConflict)
Exception message: (setuptools 40.6.3 (/root/.cache/pants/setup/bootstrap-Linux-x86_64/pants.dSeKhP/install/lib/python3.7/site-packages), Requirement.parse('setuptools==45.1.0'))
Is there a way that we can upgrade the version pants uses for setuptools on our end? And if not, is it possible to submit a PR to the pants repo which upgrades the version of setuptools pants uses behind the scenes?