damp-quill-5918702/07/2020, 5:38 PM
we're trying to run
with a target that uses the google-auth library. There is a specific issue with the library which breaks on older versions of
. Running a pytest after upgrading our setuptools version to
passes fine. When running it through pants, pants enforces
. We tried to get around this by adding in
to our pants.ini, but then we get this error.
plugins: ["setuptools_scm", "setuptools==45.1.0"]
Exception caught: (pkg_resources.VersionConflict)
Is there a way that we can upgrade the version pants uses for setuptools on our end? And if not, is it possible to submit a PR to the pants repo which upgrades the version of setuptools pants uses behind the scenes?
Exception message: (setuptools 40.6.3 (/root/.cache/pants/setup/bootstrap-Linux-x86_64/pants.dSeKhP/install/lib/python3.7/site-packages), Requirement.parse('setuptools==45.1.0'))