the only project I'm having trouble with is one th...
# general
the only project I'm having trouble with is one tha lives a directory "lib", is there any naming restriction?
Hm, what is the issue specifically? Pants places no restrictions on what you name folders, other than avoiding some characters like
. What version of Pants are you using (
./pants --version
)? Likely this is an issue with source roots. See
I'm using 1.29.0rc0 - I tried to change the
but no luck
It looks like there was a line
in .gitignore added after the directory
was created. Removing that line fixes the issue 🎉
👍 1
does pants now use this file when inspecting the repo?
Ah, good find! Indeed, Pants does use your top level gitignore to populate the option
. You can turn this off by setting
pants_ignore_use_gitignore = false
in the
section of pants.toml
Alternatively, you can override a specific value by setting
pants_ignore.add = [“!my_pattern”]
thanks, that's very helpful 🙂
❤️ 1
I’ll look on Monday at where this would be appropriate to add to the docs
👍 2
Finding this thread just solved a confusing issue for my build, plus1 on the docs 🙂
🎉 1
Awesome! @salmon-television-63321 was your issue that a folder was being ignored that you didn’t expect?
Okay updated: 1) Added a brief “tip” to the Gitignore page, which is the ~5th page we expect new users to see I didn’t want to go into detail because it’s an advanced topic. 2) Added a new entry to the Troubleshooting page: Any feedback welcome on this! 🙂
Thanks @hundreds-father-404, my context was an upgrade from 1.18 to latest plus a switch to mixed mode builds. I have a jarfile from a jvm build being treated as a resource for a python build, which worked in 1.18 even with it .gitignore’d (maybe accidentally?) but fell off the wagon toward the end 🙂
👍 1
Got it, that makes sense why that would stop working. Glad to hear you’re upgrading - let us know if we can help with anything else and if you have feedback or feature requests!
👌 thanks again, and the new docs look great!
❤️ 1