https://pantsbuild.org/ logo
b

better-nail-12700

08/12/2020, 8:29 AM
I don't know if this is just me not understanding how to use it or if there is an issue with the run goal and pantsd, but when I run any long running python binary target withh pantsd enabled, I can't seem to stop the execution. SIGINT and SIGQUIT (Ctrl+C, Ctrl+\) produce a log message, but actually don't seem to terminate the running python process. This is v1.30.0 btw. Does anyone else have a similar issue?
The messages that are produced look like this:
[INFO] Sending SIGINT to pantsd with pid 19916, waiting up to 5.0 seconds before sending SIGKILL...
The executed binary target keeps on running though
m

miniature-lamp-45970

08/12/2020, 1:56 PM
Had the same issue with 2.0.0.dev7 yesterday. But did the workaround of pgrep python | xargs ps -f -p and killed the process using kill -9
b

better-nail-12700

08/12/2020, 3:40 PM
Yeah, that's my current go to workaround as well, but that confirms that it's not only me this is happening to
w

witty-crayon-22786

08/12/2020, 4:27 PM
sorry for the trouble folks. there are some known issues here, tracked in https://github.com/pantsbuild/pants/issues/10057 … the particular issue is #10051.
it’s next on my plate after my current work, so hopefully within the week.
h

hundreds-father-404

08/12/2020, 4:55 PM
Vedavyas, the INFO log will say what the PID is, e.g. 19916 in Florian’s example. You can use
kill -9
and then that code But, yes, still not ideal as Stu mentioned
m

miniature-lamp-45970

08/12/2020, 5:02 PM
oh yes! that saves some time! Thanks!
❤️ 1
w

witty-crayon-22786

11/05/2020, 7:54 PM
@better-nail-12700, @miniature-lamp-45970: hey folks! found this thread while doing some spelunking. a bunch of changes to the Ctrl+C behavior were made in the leadup to 2.0, but if you’re still seeing issues, we’d love feedback on that.
but also: if there is anything else you’d like to see improved, or anything that would help you to get on 2.0, we’re currently gathering feedback: https://pantsbuild.slack.com/archives/C046T6T9U/p1604600533210200
m

miniature-lamp-45970

11/07/2020, 12:47 AM
Thanks @witty-crayon-22786. Still on the rc1 release, and is on my list of things to update to the 2.0 stable release. Will update you, once updated and tried.
👍 1
3 Views