https://pantsbuild.org/ logo
#general
Title
# general
j

jolly-midnight-72759

11/18/2020, 4:24 PM
I am getting a "Could not find a compatible interpreter" error with a constraint string of
CPython<3,<4,>=2.7.17,>=3.6.8 OR CPython<3,<4,>=2.7.17,>=3.6.8,>=3.6.9'
. Doesn't 2.7.17 satisfies this constraint?
a

average-vr-56795

11/18/2020, 4:27 PM
I think commas mean and, so your first clause says >=2.7.17 AND >=3.6.8
j

jolly-midnight-72759

11/18/2020, 4:28 PM
From Eric's recent blog post: "Final merged constraints: CPython==2.7.*,>=3.5 OR CPython>=3.5" resolves to 3.5+.
The formatting is strange.
h

hundreds-father-404

11/18/2020, 4:31 PM
yeah the comma means AND the first constraint is unsatisifable, same with second. The
<3
is messing things because you also have
>=3.68
and
>=3.6.9
I want to add a change to simplify constraints and eagerly detect when it’s unsatisfiable, but can’t figure out how to implement it Does
./pants py-constraints path/to/file.py
help with seeing where these constraints are coming from? Also what are you hoping this code will use?
j

jolly-midnight-72759

11/18/2020, 4:33 PM
We just made the changes we needed so we can run the v2.1.0 version. Will try that out today.
💯 1
h

hundreds-father-404

11/18/2020, 4:39 PM
I reopened https://github.com/pantsbuild/pants/issues/11072. I agree it’s really confusing to have constraints that are unsatisfiable in the final constraint - ideally, Pants would detect in this case that it’s unsatisfiable and would complain
👍🏽 1