https://pantsbuild.org/ logo
#general
Title
# general
f

few-rocket-4266

01/08/2021, 11:08 AM
Hi! I am really impressed with the pants2 build system 😄 I am trying to write my first plugin. But I have some code written with 3.8 syntax (walrus operator). How do I change it so the plugin runs with python 3.8? Currently, I tried `python_library(interpreter_constraints=["==3.8.6"])`in BUILD in the same file as the plugin sources. But it didn't work. I am using
pants_version = "2.1.1"
❤️ 4
h

hundreds-father-404

01/08/2021, 3:24 PM
Hello! Welcome! Modify the ./pants script. I'm afk but there should be a section with numbers like 3.7 and 3.8. Change the ordering Also check out the #plugins section channel
f

few-rocket-4266

01/08/2021, 3:48 PM
Thanks. That did the job 🙂
3 Views