https://pantsbuild.org/ logo
#general
Title
# general
h

helpful-lunch-92084

01/19/2021, 6:23 PM
hey, so i finally got around to trying out the new pip resolver in pex 2.1.23 via pants 2.3.0.dev0 and it still seems to be failing even though i’m passing in pip-2020-resolver to the
resolver_version
in
python-setup
. I can confirm that using pex 2.1.23 correctly resolves the following with the new resolver:
boto3==1.15.6
botocore
Pex in action:
Copy code
$ pex --version
2.1.23
$ pex boto3==1.15.6 botocore -o boto3.pex
Failed to resolve compatible distributions:
1: boto3==1.15.6 requires botocore<1.19.0,>=1.18.6 but botocore 1.19.56 was resolved
$ pex --resolver-version=pip-2020-resolver boto3==1.15.6 botocore -o boto3.pex
$
Pants in action:
Copy code
$ cat 3rdparty/python/BUILD.foo
python_requirement_library(
    name="foo",
    requirements=["boto3==1.15.6", "botocore"],
)
$ pants repl 3rdparty/python:foo
...

Engine traceback:
  in select
  in pants.core.goals.repl.run_repl
  in pants.backend.python.goals.repl.create_ipython_repl_request
  in pants.backend.python.util_rules.pex.create_pex (requirements.pex)
  in pants.engine.process.fallible_to_exec_result_or_raise
Traceback (most recent call last):
  File "/Users/nate/.cache/pants/setup/bootstrap-Darwin-x86_64/2.3.0.dev0_py38/lib/python3.8/site-packages/pants/engine/process.py", line 255, in fallible_to_exec_result_or_raise
    raise ProcessExecutionFailure(
pants.engine.process.ProcessExecutionFailure: Process 'Building requirements.pex with 2 requirements: boto3==1.15.6, botocore' failed with exit code 1.
stdout:

stderr:
Failed to resolve compatible distributions:
1: boto3==1.15.6 requires botocore<1.19.0,>=1.18.6 but botocore 1.19.56 was resolved
Any thoughts?