https://pantsbuild.org/ logo
#general
Title
# general
e

enough-analyst-54434

01/19/2021, 6:32 PM
Yeah, you want `--python-setup-resolver-version`:
Copy code
$ ./pants help-advanced python-setup
...
--python-setup-resolver-version=<ResolverVersion>
  PANTS_PYTHON_SETUP_RESOLVER_VERSION
  resolver_version
      one of: [pip-legacy-resolver, pip-2020-resolver]
      default: pip-legacy-resolver
      current value: pip-2020-resolver (from pants.toml)
      The resolver implementation to use when resolving Python requirements.
      
      Support for the 'pip-legacy-resolver' will be removed in Pants 2.5; so you're encouraged
      to start using the 'pip-2020-resolver' early. For more information on this change see
      <https://pip.pypa.io/en/latest/user_guide/#changes-to-the-pip-dependency-resolver->
      in-20-2-2020
      Upcoming deprecation in version: 2.3.0.dev1, will be removed in version: 2.5.0.dev1.