https://pantsbuild.org/ logo
#general
Title
# general
p

plain-carpet-73994

06/16/2021, 8:34 PM
I've done something very wrong but I'm not sure what. First I tried to upgrade from pants 2.4 to 2.5 by updating the version in my
pants.toml
. When I then ran
./pants typecheck
I got:
Copy code
ERROR: Could not find a version that satisfies the requirement mypy==0.818
I killed the daemon and did an
rm -rf ~/.cache/pants
but to no avail. So I tried to downgrade back to 2.4 but I get the same error but now with
mypy==0.800
. What did I do wrong and how do I fix it?
w

witty-crayon-22786

06/16/2021, 8:50 PM
was there more context above the error?
p

plain-carpet-73994

06/16/2021, 9:06 PM
I think I just figured this part out. It was, in fact, related to my 2nd question. Adding
grpc-stubs
added a dependency on later versions of mypy.
đź‘€ 1
w

witty-crayon-22786

06/16/2021, 9:23 PM
interesting… that’s surprising. the stub package depends on mypy…?
âž• 1
it doesn’t look like it does… no dependencies at all.
2 Views