https://pantsbuild.org/ logo
#general
Title
# general
p

plain-carpet-73994

08/18/2021, 10:31 PM
We just upgraded to pants 2.6. We're using the wrapper so I just changed the version in
pants.toml
. That worked as expected on my Linux machine but my coworker on OSX is seeing the following:
Copy code
sing base prefix '/Users/ckolson/.pyenv/versions/3.8.9'
New python executable in /Users/ckolson/.cache/pants/setup/bootstrap-Darwin-x86_64/pants.SsTbLj/install/bin/python3.8
Also creating executable in /Users/ckolson/.cache/pants/setup/bootstrap-Darwin-x86_64/pants.SsTbLj/install/bin/python
Installing setuptools, pip, wheel...
done.
Collecting pip
  Using cached <https://files.pythonhosted.org/packages/ca/31/b88ef447d595963c01060998cb329251648acf4a067721b0452c45527eb8/pip-21.2.4-py3-none-any.whl>
Installing collected packages: pip
  Found existing installation: pip 19.0.3
    Uninstalling pip-19.0.3:
      Successfully uninstalled pip-19.0.3
Successfully installed pip-21.2.4
ERROR: Could not find a version that satisfies the requirement pantsbuild.pants==2.6.0 (from versions: 0.0.17, 0.0.18, 0.0.20, 0.0.21, 0.0.22, 0.0.23, 0.0.24, 0.0.25, 0.0.26, 0.0.27, 0.0.28, 0.0.29, 0.0.30, 0.0.31, 0.0.32, 0.0.33, 0.0.34, 0.0.35, 0.0.36, 0.0.37, 0.0.38, 0.0.39, 0.0.40, 0.0.41, 0.0.42, 0.0.43, 0.0.44, 0.0.45, 0.0.46, 0.0.47, 0.0.48, 0.0.49, 0.0.50, 0.0.51, 0.0.52, 0.0.53, 0.0.54, 0.0.55, 0.0.56, 0.0.57, 0.0.58, 0.0.59, 0.0.60, 0.0.61, 0.0.62, 0.0.63, 0.0.64, 0.0.65, 0.0.66, 0.0.67, 0.0.68, 0.0.69, 0.0.70, 0.0.71, 0.0.72, 0.0.73, 0.0.74, 0.0.75, 0.0.76, 0.0.77, 0.0.79, 0.0.80, 0.0.81, 0.0.82, 1.0.0, 1.0.1, 1.1.0, 1.2.0, 1.2.1, 1.3.0, 1.4.0, 1.5.0, 1.6.0, 1.7.0, 1.15.0, 1.16.0, 1.17.0, 1.18.0, 1.19.0, 1.20.0, 1.21.0, 1.22.0, 1.23.0, 1.24.0, 1.25.0, 1.26.0, 1.27.0, 1.28.0, 1.29.0, 1.30.0, 1.30.1, 1.30.2, 1.30.3, 1.30.4rc0, 1.30.4, 1.30.5rc0, 2.0.0a0, 2.0.0a1, 2.0.0a2, 2.0.0a3, 2.0.0b0, 2.0.0b1, 2.0.0b2, 2.0.0b3, 2.0.0rc0, 2.0.0rc1, 2.0.0rc2, 2.0.0rc3, 2.0.0, 2.0.1rc0, 2.0.1rc1, 2.0.1rc2, 2.0.1rc3, 2.0.1rc4, 2.0.1, 2.0.2rc0, 2.0.2, 2.1.0.dev0, 2.1.0rc0, 2.1.0rc1, 2.1.0rc2, 2.1.0rc3, 2.1.0, 2.1.1rc0, 2.1.1rc1, 2.1.1rc2, 2.1.1, 2.1.2rc0, 2.1.2, 2.2.0.dev0, 2.2.0.dev1, 2.2.0.dev2, 2.2.0rc0, 2.2.0rc1, 2.2.0rc2, 2.2.0, 2.2.1rc0, 2.2.1rc1, 2.2.1rc2, 2.2.1, 2.2.2rc0, 2.2.2rc1, 2.2.2, 2.2.3rc0, 2.2.3, 2.2.4rc0, 2.2.4, 2.3.0.dev0, 2.3.0.dev1, 2.3.0.dev2, 2.3.0.dev3, 2.3.0rc0, 2.3.0rc1, 2.3.0rc2, 2.3.0rc3, 2.3.0rc4, 2.3.0, 2.3.1rc0, 2.3.1rc1, 2.3.1rc2, 2.3.1rc3, 2.3.1, 2.3.2rc0, 2.3.2, 2.3.3rc0, 2.3.3, 2.4.0.dev0, 2.4.0.dev1, 2.4.0.dev2, 2.4.0.dev3, 2.4.0rc0, 2.4.0rc1, 2.4.0rc2, 2.4.0rc3, 2.4.0rc4, 2.4.0rc5, 2.4.0, 2.4.1rc0, 2.4.1rc1, 2.4.1, 2.4.2rc0, 2.4.2rc1, 2.4.2)
ERROR: No matching distribution found for pantsbuild.pants==2.6.0
./pants: line 282: /Users/ckolson/.cache/pants/setup/bootstrap-Darwin-x86_64/2.6.0_py38/bin/python: No such file or directory
It's strange that pip can't find
pantsbuild.pants
above 2.4.2. I checked PyPi and it's there. Any ideas?
h

hundreds-father-404

08/18/2021, 10:35 PM
Hi! What version of macos are they?
p

plain-carpet-73994

08/19/2021, 4:35 PM
Thanks for the quick reply. She is, indeed, running an old version of OSX. She's going to try to upgrade tonight. I'll let you know if that doesn't solve the problem.
h

hundreds-father-404

08/19/2021, 4:41 PM
Cool, thanks Oliver! As mentioned in the thread, we should make this be an eager error in the
./pants
bash script - this is the third time it's tripped someone up this month alone 😮