https://pantsbuild.org/ logo
#general
Title
# general
c

calm-ambulance-65371

01/12/2022, 11:07 PM
Back on my Pants 2.2 -> 2.9 upgrade. Latest issue is this:
ERROR: Package '<redacted>' requires a different Python: 3.8.10 not in '>=3.8'
👀 1
Intuitively, I would expect 3.8.10 to satisfy the interpreter_constraint of >=3.8
h

happy-kitchen-89482

01/12/2022, 11:26 PM
Well that definitely seems all kinds of wrong
Can you post more of the output, and the command you're running, so we can see where this is happening?
h

hundreds-father-404

01/13/2022, 7:56 PM
Btw, not sure if you're doing this, but I recommend going one release at a time per https://www.pantsbuild.org/docs/upgrade-tips