https://pantsbuild.org/ logo
#general
Title
# general
h

hallowed-plastic-91664

01/31/2022, 12:50 AM
when do we need to update the pants shell script in the root of the repository?
i want to try out the latest dev pre-release, but I am getting this error if I run any commands after updating the .toml file with
2.10.0.dev3
Copy code
ERROR: Could not find a version that satisfies the requirement pantsbuild.pants==2.10.0.dev3 (from versions: 0.0.17, 0.0.18, 0.0.20, 0.0.21, 0.0.22, 0.0.23, 0.0.24, 0.0.25, 0.0.26, 0.0.27, 0.0.28, 0.0.29, 0.0.30, 0.0.31, 0.0.32, 0.0.33, 0.0.34, 0.0.35, 0.0.36, 0.0.37, 0.0.38, 0.0.39, 0.0.40, 0.0.41, 0.0.42, 0.0.43, 0.0.44, 0.0.45, 0.0.46, 0.0.47, 0.0.48, 0.0.49, 0.0.50, 0.0.51, 0.0.52, 0.0.53, 0.0.54, 0.0.55, 0.0.56, 0.0.57, 0.0.58, 0.0.59, 0.0.60, 0.0.61, 0.0.62, 0.0.63, 0.0.64, 0.0.65, 0.0.66, 0.0.67, 0.0.68, 0.0.69, 0.0.70, 0.0.71, 0.0.72, 0.0.73, 0.0.74, 0.0.75, 0.0.76, 0.0.77, 0.0.79, 0.0.80, 0.0.81, 0.0.82, 1.0.0, 1.0.1, 1.1.0, 1.2.0, 1.2.1, 1.3.0, 1.4.0, 1.5.0, 1.6.0, 1.7.0, 1.15.0, 1.16.0, 1.17.0, 1.18.0, 1.19.0, 1.20.0, 1.21.0, 1.22.0, 1.23.0, 1.24.0, 1.25.0, 1.26.0, 1.27.0, 1.28.0, 2.5.0rc0, 2.5.0rc1, 2.5.0rc2, 2.5.0rc3, 2.5.0, 2.5.1rc0, 2.5.1rc1, 2.5.1rc2, 2.5.1rc3, 2.5.1rc4, 2.5.1rc5, 2.5.1rc6, 2.5.1, 2.5.2rc0, 2.5.2rc1, 2.5.2rc2, 2.5.2rc3, 2.5.2, 2.6.0rc0, 2.6.0rc1, 2.6.0rc2, 2.6.0rc3, 2.6.0rc4, 2.6.0, 2.6.1rc0, 2.6.1rc1, 2.6.1rc2, 2.6.1rc3, 2.6.1, 2.7.0.dev2, 2.7.0.dev3, 2.7.0.dev4, 2.7.0rc0, 2.7.0rc1, 2.7.0rc2, 2.7.0rc3, 2.7.0rc4, 2.7.0rc5, 2.7.0, 2.7.1rc0, 2.7.1rc1, 2.7.1, 2.7.2rc0, 2.7.2rc1, 2.7.2rc2, 2.7.2, 2.8.0.dev0, 2.8.0.dev1, 2.8.0.dev2, 2.8.0.dev3, 2.8.0.dev4, 2.8.0.dev5, 2.8.0rc0, 2.8.0rc1, 2.8.0rc2, 2.8.0rc3, 2.8.0rc4, 2.8.0rc5, 2.8.0rc6, 2.8.0, 2.8.1rc0, 2.8.1rc1, 2.8.1rc2, 2.9.0.dev0, 2.9.0.dev1, 2.9.0.dev2, 2.9.0.dev3, 2.9.0.dev4, 2.9.0rc0, 2.9.0rc1, 2.9.0rc2, 2.9.0rc3, 2.9.0rc4, 2.9.0rc5, 2.9.0rc6, 2.9.0, 2.10.0.dev0, 2.10.0.dev1, 2.10.0.dev2)
ERROR: No matching distribution found for pantsbuild.pants==2.10.0.dev3
f

fast-nail-55400

01/31/2022, 1:07 AM
looks like only 2.10.0.dev2 is out currently. https://pypi.org/project/pantsbuild.pants/#history
h

happy-kitchen-89482

01/31/2022, 3:00 AM
You shouldn't need to update that script very often/at all. We're also hoping to greatly simplify it in the future by distributing Pants as a standalone binary with an embedded python interpreter, so there will be no need for the script to find one on your system
👍 1
gotcha though, ill use that page instead to watch for pre-releases 🙂
h

happy-kitchen-89482

01/31/2022, 4:01 AM
Hmm, I think the release was not completed
@wide-energy-11069, was all well with the release?
w

wide-energy-11069

01/31/2022, 4:03 AM
Will run the release script in a bit. Sorry for the delay.
h

happy-kitchen-89482

01/31/2022, 5:05 AM
Thanks!
3 Views