https://pantsbuild.org/ logo
#general
Title
# general
e

echoing-farmer-15630

03/08/2022, 1:12 PM
Minimal test case:
Copy code
pex --platform="manylinux_2_35_x86_64-cp-3.9.9-cp39" PyYAML==5.4.1
ERROR: Could not find a version that satisfies the requirement PyYAML==5.4.1 (from versions: none)
ERROR: No matching distribution found for PyYAML==5.4.1
... I can't find a way to make even a pex with just PyYAML... there are a few packages that seem to work (
requests
) and some that absolutely refuse (
MarkupSafe
). I can get the PyYAML version to get a prompt with
Copy code
❯ pex --platform="manylinux2014_x86_64-cp-3.9.9-cp39" PyYAML
WARNING: attempting to run PEX with incompatible platforms!
Running on platform manylinux_2_35_x86_64-cp-3.9.9-cp39 but built for manylinux2014_x86_64-cp-3.9.9-cp39
...so there's evidently an issue with manylinux2014 vs manylinux 2.35...?
e

enough-analyst-54434

03/08/2022, 4:06 PM
I've explained the PyYAML case over in https://pantsbuild.slack.com/archives/C046T6T9U/p1646755174368729?thread_ts=1646744312.257249&cid=C046T6T9U : In short, use a platform of
linux_x86_64-cp-3.9.9-cp39
, but I'm interested in more detail on the
MarkupSafe
case. @echoing-farmer-15630 do you have details? What version and what backtrace?
8 Views