https://pantsbuild.org/ logo
#general
Title
# general
b

big-crayon-94763

04/14/2022, 8:15 PM
I am trying to update to
2.12.0.dev2
for the new
rule_helper
function and getting this:
ERROR: No matching distribution found for pantsbuild.pants==2.12.0.dev2
looks like the package is up there though. Any idea what is going on?
p

polite-garden-50641

04/14/2022, 8:46 PM
this is likely because of python version. check which python version you are using.
hmm... I see that too.
Copy code
#11 24.64   activators BashActivator,CShellActivator,FishActivator,PowerShellActivator,PythonActivator,XonshActivator
#11 26.71 Requirement already satisfied: pip in ./.cache/pants/setup/bootstrap-Linux-x86_64/pants.SqQwYf/install/lib/python3.8/site-packages (21.1.2)
#11 27.10 Collecting pip
#11 27.23   Downloading pip-22.0.4-py3-none-any.whl (2.1 MB)
#11 27.48 Installing collected packages: pip
#11 27.48   Attempting uninstall: pip
#11 27.48     Found existing installation: pip 21.1.2
#11 27.91     Uninstalling pip-21.1.2:
#11 27.93       Successfully uninstalled pip-21.1.2
#11 29.87 Successfully installed pip-22.0.4
#11 32.01 ERROR: Could not find a version that satisfies the requirement pantsbuild.pants==2.12.0.dev2 (from versions: 0.0.17, 0.0.18, 0.0.20, 0.0.21, 0.0.22, 0.0.23, 0.0.24, 0.0.25, 0.0.26, 0.0.27, 0.0.28, 0.0.29, 0.0.30, 0.0.31, 0.0.32, 0.0.33, 0.0.34, 0.0.35, 0.0.36, 0.0.37, 0.0.38, 0.0.39, 0.0.40, 0.0.41, 0.0.42, 0.0.43, 0.0.44, 0.0.45, 0.0.46, 0.0.47, 0.0.48, 0.0.49, 0.0.50, 0.0.51, 0.0.52, 0.0.53, 0.0.54, 0.0.55, 0.0.56, 0.0.57, 0.0.58, 0.0.59, 0.0.60, 0.0.61, 0.0.62, 0.0.63, 0.0.64, 0.0.65, 0.0.66, 0.0.67, 0.0.68, 0.0.69, 0.0.70, 0.0.71, 0.0.72, 0.0.73, 0.0.74, 0.0.75, 0.0.76, 0.0.77, 0.0.79, 0.0.80, 0.0.81, 0.0.82, 1.0.0, 1.0.1, 1.1.0, 1.2.0, 1.2.1, 1.3.0, 1.4.0, 1.5.0, 1.6.0, 1.7.0, 1.15.0, 1.16.0, 1.17.0, 1.18.0, 1.19.0, 1.20.0, 1.21.0, 1.22.0, 1.23.0, 1.24.0, 1.25.0, 1.26.0, 1.27.0, 1.28.0, 1.29.0, 1.30.0, 1.30.1, 1.30.2, 1.30.3, 1.30.4, 1.30.5rc1, 2.0.0, 2.0.1, 2.0.2, 2.1.0, 2.1.1, 2.1.2, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.4.0, 2.4.1, 2.4.2, 2.5.0, 2.5.1rc5, 2.5.1rc6, 2.5.1, 2.5.2rc0, 2.5.2rc1, 2.5.2rc2, 2.5.2rc3, 2.5.2, 2.6.0rc0, 2.6.0rc1, 2.6.0rc2, 2.6.0rc3, 2.6.0rc4, 2.6.0, 2.6.1rc0, 2.6.1rc1, 2.6.1rc2, 2.6.1rc3, 2.6.1, 2.7.0rc0, 2.7.0rc1, 2.7.0rc2, 2.7.0rc3, 2.7.0rc4, 2.7.0rc5, 2.7.0, 2.7.1rc0, 2.7.1rc1, 2.7.1, 2.7.2rc0, 2.7.2rc1, 2.7.2rc2, 2.7.2, 2.8.0.dev5, 2.8.0rc0, 2.8.0rc1, 2.8.0rc2, 2.8.0rc3, 2.8.0rc4, 2.8.0rc5, 2.8.0rc6, 2.8.0, 2.8.1rc0, 2.8.1rc1, 2.8.1rc2, 2.9.0.dev0, 2.9.0.dev1, 2.9.0.dev2, 2.9.0.dev3, 2.9.0.dev4, 2.9.0rc0, 2.9.0rc1, 2.9.0rc2, 2.9.0rc3, 2.9.0rc4, 2.9.0rc5, 2.9.0rc6, 2.9.0, 2.9.1rc0, 2.9.1rc1, 2.9.1rc2, 2.9.1, 2.9.2rc0, 2.10.0.dev0, 2.10.0.dev1, 2.10.0.dev2, 2.10.0.dev3, 2.10.0rc0, 2.10.0rc1, 2.10.0rc2, 2.10.0rc3, 2.10.0rc4, 2.10.0rc5, 2.10.0, 2.10.1rc0, 2.11.0.dev0, 2.11.0.dev1, 2.11.0.dev2, 2.11.0.dev3, 2.11.0rc0, 2.11.0rc1, 2.11.0rc2, 2.12.0.dev0, 2.12.0.dev1)
#11 32.01 ERROR: No matching distribution found for pantsbuild.pants==2.12.0.dev2
------
I think there is likely an issue with how this version was published. @enough-analyst-54434 @witty-crayon-22786
this failure trying to bootstrap pants in a docker container with the base image of
python:3.8.12-slim-buster@sha256:7e732593f25983fa7d4b2d54444be4a785f2397c1cf2f815d2e3638337eee012
e

enough-analyst-54434

04/14/2022, 9:01 PM
Copy code
$ unzip -qc pantsbuild.pants-2.12.0.dev2-cp37-cp37m-manylinux2014_x86_64.whl pantsbuild.pants-2.12.0.dev2.dist-info/METADATA | grep Requires-Python
Requires-Python: ==3.7.*
$ unzip -qc pantsbuild.pants-2.12.0.dev2-cp38-cp38-manylinux2014_x86_64.whl pantsbuild.pants-2.12.0.dev2.dist-info/METADATA | grep Requires-Python
Requires-Python: ==3.8.*
$ unzip -qc pantsbuild.pants-2.12.0.dev2-cp39-cp39-manylinux2014_x86_64.whl pantsbuild.pants-2.12.0.dev2.dist-info/METADATA | grep Requires-Python
Requires-Python: ==3.9.*
No bueno. Although those
Requires-Python
are all true, You cannot have different metadata per instance of a given publish project version or else it breaks assumptions made by all known Python resolvers.
So basically Pip downloaded 1
pantsbuild,pants
wheel - probably cp37m, and got its metadata from it once and assumes that's the case for all instances and says no can do for Python 3.8.
b

big-crayon-94763

04/14/2022, 9:02 PM
I am using Python 3.10.4 and running into the same thing
e

enough-analyst-54434

04/14/2022, 9:02 PM
Thanks Asher - Andreus did work here that I reviewed. I pointed this exact issue out in review and he and I thought it was handled, but it is not.
Yeah, all should be broken.
I'll get out a fix PR here and I think the dev2 will just stay broken if that's OK - we can yank - and the fix will be in dev3 tomorrow.
👍 1
@big-crayon-94763 and @polite-garden-50641 make sense? and sound good?
p

polite-garden-50641

04/14/2022, 9:05 PM
it works in other scenarios, For the Toolchain repo, in CI it works for example... so I don't think we should yank... but getting dev3 out tomorrow sgtm.
b

big-crayon-94763

04/14/2022, 9:05 PM
sounds good!
e

enough-analyst-54434

04/14/2022, 9:05 PM
OK. Yeah - it could work randomly if Pip happens to 1st download the version that matches the interpreter you're using.
👍 2
h

hundreds-father-404

04/14/2022, 9:13 PM
Thank you for the report Kevin!
e

enough-analyst-54434

04/14/2022, 9:14 PM
Ah - reviewer error. My bad. I didn't keep my on this ball: https://github.com/pantsbuild/pants/pull/15071#discussion_r846672293 We did discuss this very issue but it was only fixed for 1 of the 2 pantsbuild dists - testutil:
Copy code
$ unzip -qc pantsbuild.pants.testutil-2.12.0.dev2-py3-none-any.whl pantsbuild.pants.testutil-2.12.0.dev2.dist-info/METADATA | grep Requires-Python
Requires-Python: >=3.7,<3.10
c

curved-television-6568

04/15/2022, 11:09 AM
Sorry for the trouble. 🙏