https://pantsbuild.org/ logo
#general
Title
# general
e

eager-crayon-52125

04/28/2022, 1:49 PM
Here goes first: trying to run
pants test --test-use-coverage
fails on M1 with a message such as
Copy code
1.) The wheel tags for coverage 5.5 are cp38-cp38-macosx_10_14_arm64 which do not match the supported tags of /Library/Developer/CommandLineTools/Library/Frameworks/Python3.framework/Versions/3.8/bin/python3.8:
h

hundreds-father-404

04/28/2022, 1:59 PM
Hello! I am an M1 user too, and I have had much more success using Python 3.9 or newer. 3.8 only has partial support If you have not yet, you will want to change your interpreter constraints to 3.9 (or greater) https://www.pantsbuild.org/docs/python-interpreter-compatibility#setting-the-default-python-version If you cannot yet change the setting for your entire project, you can use a pants. RC file to override your local config https://www.pantsbuild.org/docs/options#pantsrc-file
e

eager-crayon-52125

04/28/2022, 2:03 PM
Thanks Eric for replying! I already changed to >= 3.9, which did not help.
h

hundreds-father-404

04/28/2022, 2:12 PM
https://github.com/pantsbuild/pants/issues/11137 is the idea to fix this wart. Although usually, it does not matter what version of Python you use to run coverage. It only matters here because of M1
e

eager-crayon-52125

04/28/2022, 5:26 PM
Thanks @hundreds-father-404, that did the trick!
❤️ 1
5 Views