Q27: Now I'm applying pants to my CI. To workaroun...
# general
Q27: Now I'm applying pants to my CI. To workaround the error in the first screenshot as instructed, I've changed
./pants --version
./pants --version --no-verify-config
, it says another error as in the second screenshot. Why is pants complaining about my pants.toml and how to fix this seem-to-be-bogus error? Here is my pants.toml.
I think you get the errors in the first screenshot on the left due to the python backend not being enabled, and the second hints that your option needs to go on global scope, i.e. before any goals, so this should help with that:
Copy code
./pants --no-verify-config --version
or just
./pants --no-verify-config version
will make it more clear that
is a goal, rather than a flag.
👍 1
I think the options parsing regarding help/version is a bit on the liberal side…
Can I enable both normal and experimental version of the python backend?
i.e., Does twine-based pypi publish target require the experimental python backend?
Another check error I'm facing is:
I think the docs does not say anything about other requirements of this config (e.g., pants version)
Yes you can mix and match experimental backends.
🙌 1
Regarding your error message, there's a typo in it. Missing a d in dependency. If that could be it..? :)