https://pantsbuild.org/ logo
#general
Title
# general
g

green-match-66337

05/12/2022, 11:43 AM
Copy code
ProcessExecutionFailure: Process 'Building template_get/lambda.zip with 1 requirement: aws-lambda-powertools==1.25.10' failed with exit code 1.
stdout:

stderr:
ERROR: Cannot install aws-lambda-powertools because these package versions have conflicting dependencies.
ERROR: ResolutionImpossible: for help visit <https://pip.pypa.io/en/latest/user_guide/#fixing-conflicting-dependencies>
pid 30265 -> /Users/andy.challis/.cache/pants/named_caches/pex_root/venvs/4a4903f4a53b18a8968a4b2bac7896c88ae1b1da/cda4085b8dca33309a87eb474877cbd3a6659e25/pex --disable-pip-version-check --no-python-version-warning --exists-action a --isolated -q --cache-dir /Users/andy.challis/.cache/pants/named_caches/pex_root --log /private/var/folders/44/2rnr2jp97g1ddjr20xccsvv40000gn/T/process-executionYYi5SJ/.tmp/pex-pip-logfc_g6lfa/pip.log download --dest /private/var/folders/44/2rnr2jp97g1ddjr20xccsvv40000gn/T/process-executionYYi5SJ/.tmp/tmpjrsxhnm8/cp39-cp39-linux_x86_64 --only-binary :all: aws-lambda-powertools==1.25.10 --platform manylinux2014_x86_64 --platform linux_x86_64 --implementation cp --python-version 39 --abi cp39 --index-url <https://pypi.org/simple/> --retries 5 --timeout 15 exited with 1 and STDERR:
 
 The conflict is caused by:
     aws-xray-sdk 2.9.0 depends on future
     aws-xray-sdk 2.8.0 depends on future
 
 To fix this you could try to:
 1. loosen the range of package versions you've specified
 2. remove package versions to allow pip attempt to solve the dependency conflict




Use `--no-process-cleanup` to preserve process chroots for inspection.
4 Views